[Scribus] Problem compiling with QT 4.3

avox avox
Mon Jul 16 22:36:27 CEST 2007

Thomas Zastrow-4 wrote:
> Hello,
> certainly, this is a stupid question ... but I can't find the answer ... :
> I tried to compile 1.3.5 from SVN. The cmake command gives me the error:
> CMake Error: The installed Qt version 4.2.1 is too old, at least version 
> 4.3.0 is required
> OK, so I downloaded the newest QT and compiled/installed it to:
>  /usr/local/Trolltech/Qt-4.3.0
> I set the variable QTDIR to that directory, but cmake still says that 
> the Qt version is too old. I'm not sure, where I can tell them to use 
> the new qt-version in /usr/local/Trolltech/Qt-4.3.0 ...??

I usually do it this way:

a) make sure qmake from 4.3.0 is first in PATH ("which qmake")
b) ccmake path/to/Scribus
c) in ccmake: toggle advanced mode ('t'), then check that all QT_* entries
point to Qt 4.3

NOT_FOUND entries usually dont matter much, but my cmake regularly picks the
wrong uic/moc executables, so I fix those manually.

d) configure (repeat until no more errors and generate option appears),
generate, make


View this message in context: http://www.nabble.com/Problem-compiling-with-QT-4.3-tf4090850.html#a11630474
Sent from the Scribus mailing list archive at Nabble.com.

More information about the scribus mailing list