[Scribus] Problem compiling with QT 4.3

Owen rcook
Wed Jul 18 01:44:11 CEST 2007

On Mon, 16 Jul 2007 22:05:07 +0200
Thomas Zastrow <listen at thomas-zastrow.de> wrote:

> Hello,
> certainly, this is a stupid question ... but I can't find the answer ... :
> I tried to compile 1.3.5 from SVN. The cmake command gives me the error:
> CMake Error: The installed Qt version 4.2.1 is too old, at least version 
> 4.3.0 is required
> OK, so I downloaded the newest QT and compiled/installed it to:
>  /usr/local/Trolltech/Qt-4.3.0
> I set the variable QTDIR to that directory, but cmake still says that 
> the Qt version is too old. I'm not sure, where I can tell them to use 
> the new qt-version in /usr/local/Trolltech/Qt-4.3.0 ...??

Just for the record, I built Qt-4.3 in /usr/local

Then (on linux)  export PATH=/usr/local/Qt-4.3.0/bin:$PATH (Found that in Qt INSTALL)

Then removed CMakeCache.txt (That's in the wiki I think)

Then re-ran cmake. 

1.3.5 sort of works and sort of doesn't work, and looking at the road map, I won't worry about it for a while, I expect the developers will indicate when everything has gone to Qt-4.3


More information about the scribus mailing list