[scribus] Lost Template Access in

John Culleton john at wexfordpress.com
Thu Jul 3 18:26:00 CEST 2008

On Wednesday 02 July 2008 10:10:55 pm Rich Shepard wrote:
> On Wed, 2 Jul 2008, John Culleton wrote:
> > I restored it by using the cmake process instead of the
> > ./configure process.  AFAICT only cmake really works 1ith
> >
>    Thanks, John. I'll rebuild it tomorrow. I've been using the
> SlackBuild script, but apparently it fails on this version. I hope
> the developers fix this bug in the next release.
> Ric
> h 

It's not a bug but a feature. The developers don't like the 
older ./configure method.  It makes their job harder. So here is the 

After you download and unpack the source files go to the directory 
holding them and use the following information (cribbed in part from 
Greg Pittman) to create Scribus:

First you have to select a work directory name.  You can use the same 
directory but the powers that be recommend against it. 
Let's say you specify /opt/scribus13312/
Then execute the following:

cmake  .  -DCMAKE_INSTALL_PREFIX:PATH=/opt/scribus13312/
(Don't forget the period after cmake!

When you install, in addition to other essential ingredients, Scribus 
will make a /opt/scribus13312/bin/scribus as the final destination of 
the executable -- it creates a bin/ directory for the binary 

This of course will not automatically be in your search path for 
executables, so you can either add this to your seach path or make an 
application icon which knows to go to this place for the binary.

Alternatively I suggest just doing:
ln -s /opt/scribus13312/bin/scribus /usr/local/bin

All other workarounds that have been suggested didn't work for 
me.  ./configure is dead for Scribus---long live cmake!

John Culleton
Resources for every author and publisher:

More information about the scribus mailing list