[scribus] svn problem

Craig Ringer craig at postnewspapers.com.au
Wed May 28 06:03:09 CEST 2008

Roger wrote:
> HI all
> Linux FC8 on intel mb and P4 cpu, have run Scrivus 1.3.5 for a few weeks.
> I just downloaded what appears to be a late version of Scribus 1.3.5. thinking 
> it may be the new 1.3.6
> svn co svn://scribus.info/Scribus/trunk/Scribus
> When compiled it had no icons on the tool bar, just a series of menu items 
> requiring several clicks to access any item
> text and image boxes, lines, etc and there seem to be no way of making a 
> rectangular coloured panel without going thru hoops, is this correct or am I 
> doing something wrong.

Did you install it?

If you don't run `make install' it'll be looking for its icons and other 
resources in the install location but not finding them.

> Anyhow this new version overwrote the previous 1.3.5 which did have icons, ok so 
> far, I guess.

I guess you did run make install.

If you want to keep separate copies, use 
-DCMAKE_INSTALL_PREFIX=/path/to/somewhere/else to specify a different 
install directory.

>   I note that the /bin,  /include,  /lib, and  /share  folders are all locked, 
> does this prevent the user from saving?

No. They should be read-only to normal users if you installed as root.

I personally prefer to install to my home directory as a normal user 
rather than installing as root when I'm testing software. So I use a 
prefix that starts with /home/craig like /home/craig/scribus/135svn .

Craig Ringer

More information about the scribus mailing list