[Scribus] PDF X-3 wont play for me in 1.3.4

Gregory Pittman gpittman
Tue Sep 25 15:27:44 CEST 2007

Louis Desjardins wrote:
> 2007/9/25, Craig Ringer <craig at postnewspapers.com.au 
> <mailto:craig at postnewspapers.com.au>>:
>     Christoph Sch?fer wrote:
>     > Am Dienstag, 25. September 2007 00:31 schrieb Calum Polwart:
>     >> When I try to save a PDF X-3 doc in 1.3.4 it disables the Save
>     Button?
>     >> Any ideas why?
>     >>
>     >> Steps to reproduce: Click PDF (it defaults to PDF 1.3), switch
>     to X-3 -
>     >> the previously enabled save button now gets greyed out...
>     >>
>     >
>     > I bet you forgot to enter the info string in the PDF/X-3 tab.
>     The fact that this has to be asked illustrates that this is a real UI
>     issue. Better options include connect(...) ing the save button to
>     a "you
>     forgot to enter the UI string" dialog invocation, or having a label
>     indicating why it can't be saved yet.
> I agree! Maybe we can look at putting there the name of the job as a 
> default settings.
> Side note : there are 8 bug reports on PDF/X-3 and just about half of 
> these discuss the UI issues. ;)
There is a complexity to the PDF export requestor that I still do not 
fully understand. Perhaps it needs one or more help buttons that bring 
up a small window explaining the purpose of various settings.
If this works, it might also be done for the various features related to 
PDF forms, which I also find confusing. Sometimes all you need is a 
quick reminder rather than diving into the online docs or going to the 
Wiki. Tooltips are Ok, but are terse and sometimes cryptic.


More information about the scribus mailing list