[scribus] Littlecms

Owen rcook at pcug.org.au
Thu Jul 17 00:40:36 CEST 2008

On Wed, 16 Jul 2008 13:53:04 -0400
Gregory Pittman <gpittman at iglou.com> wrote:

> Oleksandr Moskalenko wrote:

> > I have been thinking about replacing 1.3.4-based scribus-ng with
> > 1.3.5svn-based one for a while now. Though it might be too late to
> > introduce this change into the main Debian archive I am getting
> > more and more convinced that I should go ahead and do this in our
> > upstream Scribus Archive. What would the users of my packages think
> > of this? I welcome your suggestions. 

> Not an Ubuntu user, but it makes more sense to have 1.3.5 than 1.3.4.
> At least it would be something usable.

Just to say I run 1.3.5 on Ubuntu-8.04 and it is real nice, my simple
stuff has caused no problems.

It requires Cmake and you need at least the Qt4 stuff, from the

        Qt >= 4.3.0 (Scribus has specific code requiring Qt 4.3, not Qt
4.2.x) Freetype >= 2.1.7 (2.3.x strongly recommended)
        cairo >= 1.4.x
        libtiff >= 3.6.0
        LittleCMS (liblcms) = 1.12 (1.15+ recommended)
        libjpeg (depending on how Qt is packaged)

        Fontconfig >= 2.0
        LibXML2 >= 2.6.0
        GhostScript >= 8.0 (8.56 or greater preferred)
        Python >= 2.3
        tkinter for the font sampler script
        python-imaging for the font sampler preview
        pkgconfig (to assist finding other libraries)
        apspell for the spell checker
        podofo - 0.5.0 for enhanced Illustrator AI/EPS import, svn
versions after 0.5.0 have a different API and Scribus will not compile
using newer versions currently

PoDoFo is at version 6, don't know where you would get version 5. 
Qt is up to 4.4.0 but most distros have 4.3 versions



More information about the scribus mailing list