[scribus] Glyphs in a font not appearing

John Jason Jordan johnxj at comcast.net
Mon Jun 15 04:08:35 CEST 2009

On Sun, 14 Jun 2009 20:09:28 -0400
Gregory Pittman <gregp_ky at yahoo.com> dijo:

> >> Story Editor is only representing what it is given from the font
> >> selection you have made for the rest of your windowing system, so all of
> >> the Qt apps native GUI controls will have those characters. Unless Story
> >> Editor was rewritten to use the canvas then this would not be possible
> >> to change.
> >>
> >> Old bug, not much we can do at this point.

> > Fair enough.
> >
> > Perhaps the dialog box where the user sets the font for Story Editor
> > could have a warning explaining the limitations of the Story Editor
> > display. 
> >
> > I'm just trying to think of something that would prevent others from
> > making the mistake that I did.

> What I do is to verify whether the font has a given character by trying 
> Insert > Glyph, where you can see an accurate display of the characters 
> by code to see whether they exist or not.

Good idea. Doesn't work for me, though, and not for all those users who
use a word processor for their writing.

I do almost all the writing in OOo Writer. The only things I write in
Scribus are those few little additions that are needed during the
layout process. OOo lies about characters in a font similarly to Story
Editor. And when I do add something in Story Editor I use the Unicode
numbers, because I have memorized most of the 100+ ones that I use all
the time.

This is a good discussion. In my case I now know to do my proofreading
from the text frame. I'm just worried about other users thinking they
have a glyph because it appeared in their word processor, and in Story
Editor, and when they get the expensive print job off the press there
are missing glyphs.

Maybe I'm worrying overly much.

More information about the scribus mailing list